Ghost unable to service Mode

Log in to reply

This topic contains 51 replies, has 14 voices, and was last updated by  mikeyp13 3 months ago.

Viewing 15 posts - 1 through 15 (of 52 total)
  • Author
    Posts
  • #69937
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    Hi All

     

    Have a Ghost installed onto the RS and was able to place this into service mode, The car had to go into the dealership to do some software updates to all the modules and to have the PCM and Sync software updated due to a few issues, I am now unable to place the car back into service mode, I am doing the same process as before, Im still able to start the car as normal with entering in the correct pin and also is able to connect to the Ghost Bluetooth app.

     

    I have tried the process with ignition turn on, Enter Pin, Wait for the confirmation, enter the service button 5 times and this is when it should enter service mode.

    Also made sure that when trying this the bluetooth on my device is disabled.

     

    I have also disconnected the battery and left for 15 minutes to see if this might help however this still has not allowed the ghost to go back into service mode.

    I need to place the car back into service mode as the car is going back in to have some more work done to it.

     

    Any ideas why this is happening ?

     

    Thanks

     

    #69945

    9designs
    Participant

    UK - England

    Posts: 687

    Try putting into service mode with engine still running, before you turn it off.



    Magnetic Grey-Full spec,  FPM375, Quaife LSD, MT Springs, DSC Suspension Control Unit, MT- Short shift and switched fake noise!

    UK seller for DSC Active suspension control modules

    #69952
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    thanks for the reply, I’ve already tried this and it didn’t work, any other ideas which may work ?

     

    thanks

    #69973

    9designs
    Participant

    UK - England

    Posts: 687

    Think it’s going to be back to the installer.



    Magnetic Grey-Full spec,  FPM375, Quaife LSD, MT Springs, DSC Suspension Control Unit, MT- Short shift and switched fake noise!

    UK seller for DSC Active suspension control modules

    #69974
    71-bda
    71-bda
    Participant

    UK - England

    Posts: 2860

    who you gonna call ?



    No nothing.

    No Mods.

    No tack.

    Std as Ford intended.

    Innit.

    #69978
    howsey
    howsey
    Participant

    UK - Wales

    Posts: 1070

    🤔

    #69979
    howsey
    howsey
    Participant

    UK - Wales

    Posts: 1070

    Very good, Mike. Very good.

    #69996
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Can you change your pin code ?

    #70002
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    Hi Chris

     

    im able to change the pin code for the ghost

     

    ive also just tried to enter service mode with the new pin but it’s still not working

     

    thanks

    #70007
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    And your on cruise control ?

    #70008
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Did you contact your installer on Friday ?

    #70009
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    ive contacted the installer yesterday to inform him and hes asked me to try all the following but none of this has worked, maybe autowatch may need to be aware of this issue as other people may have the software update for the car and this could affect them ?

    Ive been driving the car today fine with cruise control and speed limiter, Im able to start the car by entering the Pin or either by the Bluetooth app.

    Do you have any ideas why this has happened ?

    It seems to be the service button may have been wiped when updating the software, before the car went in GHOST was placed into service mode.

    Thanks

    #70010
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    When was your system installed ?

    have you tried ghost disarmed via the button sequence not app, start the engine and then 5 indicator right slight lift ?

    I had an installer ring me just after lunch on Friday regarding this same issue, my car had all the updates and was fine but obviously I had the latest software on my Ghost

    #70014
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    The system was installed in September, the car is a 16 Plate RS.

     

    by any chance the installer wasn’t called Dave ?

     

    Tried that aswell Chris, turned on Ignition enter pin, wait for the 2 flashes, start car, then right indicator slight press up 5 times and nothing happens.

     

    has there recently been a update for the software for the ghost ?

    #70016
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Yes it was Dave

    And yes you need a software update which will also sort out the sync loosing an hour and headlights strobing, and give you a 15 minute valet instead of the 3 minute

    Lots of updates since September

Viewing 15 posts - 1 through 15 (of 52 total)

You must be logged in to reply to this topic.

Login or register below to contribute to Ghost unable to service Mode. If you're not already a member then you can register for free!