Ghost unable to service Mode

Log in to reply

This topic contains 51 replies, has 14 voices, and was last updated by  mikeyp13 3 months, 1 week ago.

Viewing 15 posts - 16 through 30 (of 52 total)
  • Author
    Posts
  • #70017
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    Was probably down to me, as I called him on friday as thats when the car went in for the updates and I wasn’t able to place this back into service mode and had the engine light flashing 7 times, due to the software update the accelerator pedal had been erased.

    He did inform me that I had the latest firmware for the Ghost but as you said there has been a recent firmware update released. Do you know when this was released?

    Does the software update take very long to complete ?

     

    #70020
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Software is a 2 minute job, if yours was fitted in September and you’ve never had update it’s well out of date.

    February was the sync update fix and July all Ghost software got an update to 15minute valet/service mode

    #70030
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    this was only fitted last month, has there been an update since then ?

    he did inform me that I already had the latest update ?

     

    #70038
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Sorry I thought you meant September 16 in your previous post.

    We stopped fitting cruise option in March, as most wanted drive away door locking and total closure on walk away.

     

    #70039
    central1254
    central1254
    Participant

    UK - England

    Posts: 94

    Chris,

    just as a matter of interest, how do you know if your Ghost needs an update and if it does how do you get it done?

    (Ghost fitted April 2017)

    #70042
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    That’s okay Chris.

    Have you ever seen this where the Ghost doesn’t enter service/Valet Mode. I need to get this working again as the car is going back into the dealership to have some more work completed.

    just seems that the updated software modules have wiped the service mode for the ghost

     

     

     

     

     

     

    #70061
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Can you wipe your app connection and relearn your phone ?

    Will tell me if service button is working by doing this

    #70062
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Central 1254 yours needs an update, I did a few at Ford Fair, can post you the usb and software so you can do yours and your brothers ?

    Best to email me though or text

    #70066
    Skillboy
    Skillboy
    Participant

    UK - England

    Posts: 17

    Chris

    do you have any instructions on how to Re-pair the devices after forgetting ?

    Will try this tonight when I’m home.

    Is there a number which you are best contactable on ?

    Thanks

     

    #70067

    jonyboy
    Participant

    UK - England

    Posts: 254

    Hi Chris mine was fitted late Feb early March

    you did a software update at Mountune cars and coffee in March

    i take mine needs an update

    #70070

    9designs
    Participant

    UK - England

    Posts: 691

    We could do with a version and release date log of software updates so we know if any are needed.



    Magnetic Grey-Full spec,  FPM375, Quaife LSD, MT Springs, DSC Suspension Control Unit, MT- Short shift and switched fake noise!

    UK seller for DSC Active suspension control modules

    #70071
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Unfortunately as the names on the fitting sheets don’t match your user names I’m stumped 🤔

    updates has been covered on different ghost posts and in my opinion there are to many ghost threads on this forum.

    20/07/17 is the very latest ghost firmware and also will be the last as I’m doing no more on the mk3 focus.

    #70072
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    Jonyboy I did update yours at mountune and I thought I flashed it again when I put your cameras in ?

     

    #70073
    Chris Preston
    Chris Preston
    Participant

    UK - England

    Posts: 543

    My number is :07956135770

    Use the phone to erase both ghost and app so do the erase when in the car

    #70095

    jonyboy
    Participant

    UK - England

    Posts: 254

    Chris I only had cameras fitted nothing else done

Viewing 15 posts - 16 through 30 (of 52 total)

You must be logged in to reply to this topic.

Login or register below to contribute to Ghost unable to service Mode. If you're not already a member then you can register for free!