Service due warning on dash ?

Log in to reply

Home Forums Performance General Service due warning on dash ?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #65053

    Steve Gerrard
    Participant

    United Kingdom

    Posts: 39

    Anyone had this car is 4 months old not due a service yet

     

    #65055

    71-bda
    Participant

    UK - England

    Posts: 8090

    wow! you must have been driving that hard and done loads of track days!



    No nothing.

    No Mods. No rockers. Just a chunky knob, thats now been replaced by an RS knob innit.

    No tackiness.

    Std as Ford intended, but with a space saver wheel and jack and nuts and wheel brace. oh.. and flaps, a man has got to have flaps.

    Innit?

     

    #65056

    Steve Gerrard
    Participant

    United Kingdom

    Posts: 39

    If only

    #65065

    Kenny
    Keymaster

    UK - Scotland

    Posts: 3869

    Could it mean an issue?

    #65067

    Adw
    Participant

    UK - England

    Posts: 410

    Had any DTC’s show up before? Maybe certain ones could trigger this?



    Mods:

    AccessPort / Stratified tune + STuned extended pops & bangs + custom pop and bang intensity / Boomba Racing short throw plate / DMB inlays / Mountune air filter / Mountune RMM / Mountune Recirc / Milltek Non Res Cat Back

    #65076

    Steve Gerrard
    Participant

    United Kingdom

    Posts: 39

    Nothing showing going to call Ford today And will post update when I know more

    #65098

    wackka
    Participant

    UK - England

    Posts: 83

    when was build date?



    Racing is life

    #65102

    muzzie
    Participant

    UK - England

    Posts: 77

    I had this issue with my RS, when I took it into the dealership I was told “the RS has an algorithm built in to ECU to assess how hard it being driven vs oil temperature / condition”. Not sure how true this is, but that’s what I told. This happened to me at about 8000 miles, fortunately I changed the oil and filter at 6000 miles as an addition precaution and peace of mind, but I didn’t reset the service computer. When I explained this to the technician and showed him the service history, including the receipt for the Genuine Ford parts, he cleared the service warning from the computer and all was well.

    However, please let me know if they tell you anything different as this would help with my current situation.

    Not to worry you, as it may not be related, but 1300 mile after this issue my RS is currently sat at the dealership with a blown head gasket.

    #65110

    Steve Gerrard
    Participant

    United Kingdom

    Posts: 39

    Hi

    car was built March this year, spoken with the workshop supervisor at my local dealer.

    it would appear the service indicator wasn’t reset at PDI by tech

    he has talked me through how to reset via using pedals so well see how we go

    oil and water levels are spot on, car is always warmed up correctly until cold start switches off before being driven off

    cheers

     

    #65254

    johnny10hands
    Participant

    UK - England

    Posts: 27

    I had that after a spanking coming off a roundabout 2 weeks ago. Was in normal mode and it came up as the back end stepped out of line before stepping back in. Thought that it may be because being in normal mode the exhaust flap is closed (?)

    Pulled over in lay-by. switched off ignition and switched on again. OK and no reoccurrence (so far). April 17 car with 5k on clock

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.

Please login or register to view this page.




Login or register below to contribute to Service due warning on dash ?. If you're not already a member then you can register for free!