engine failure

Log in to reply

Home Forums Performance Engine engine failure

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #20190

    bigblock
    Participant

    Spain

    Posts: 14

    Dear all,

    Yesterday I went out to drive arround very nice roads with some friends and while I was at 110 miles per hour sudently the injection was cut and engine failure. I have stopped the car 5 mins and everything  was ok, i thought it was a temperature issue despite of the outside temperature was 1 celcius.

    After 10 more miles inside a town and very slow the problem appeard again, engine failure and the engine was shot down.

    Today is at ford service but anyone has any idea?

     

    I will attached some pictures from yesterday

    #21242

    bigblock
    Participant

    Spain

    Posts: 14

    Dear all,

    Some friends told me that they have read in other forums that this is caused because of the rear differential temperature, what do you think? Ford  couldnt give me a convionceble answer.

     

     

    #21263

    sedde
    Participant

    Greece

    Posts: 51

    Did it say “awd malfunction” ?

     

    #21602

    bigblock
    Participant

    Spain

    Posts: 14

    No it didnt!  just engine failure!  but it is very weird because the ecu didnt save the error!

    #21764

    Scunner
    Participant

    United Kingdom

    Posts: 45

    Check your coolant levels. There has been a few head gasket failures recently needing new engines.

    #74722

    crazyjonah
    Participant

    UK - England

    Posts: 10

    My car.. 8 months old, 2017 March.

    No tracks days, yet. 3100 miles… coolant lose. Call from Ford after master technician inspection.. new engine!

    Car was run in correctly, never pushed unless water temp up and oil at 75 degrees …WTF is going on?

    #74732

    o1turbo30v
    Participant

    USA

    Posts: 160

    @crazyjonah and bigblock sorry to hear about your cars but unfortunately it’s not uncommon, Ford claims to be working on a fix.

    #74736

    71-bda
    Participant

    UK - England

    Posts: 8091

    110mph at 1 degree above freezing?  sounds sensible !!. Ive got frost on the roads  here  and a bit of black ice and its 3c….



    No nothing.

    No Mods. No rockers. Just a chunky knob, thats now been replaced by an RS knob innit.

    No tackiness.

    Std as Ford intended, but with a space saver wheel and jack and nuts and wheel brace. oh.. and flaps, a man has got to have flaps.

    Innit?

     

    #81857

    Tina
    Participant

    UK - England

    Posts: 1

    My car not quite 12 months old 2017 March just died on 26th Feb, after just over two weeks with the Ford dealer now have confirmed new engine needed! No previous issue, no warning, no idea why ?

    #81864

    Kenny
    Keymaster

    UK - Scotland

    Posts: 3869

    Heard of a few engines going now that are not headgasket related.

    What happened to yours Tina?

    #81872

    71-bda
    Participant

    UK - England

    Posts: 8091

    maybe its the broken piston skirt issue..



    No nothing.

    No Mods. No rockers. Just a chunky knob, thats now been replaced by an RS knob innit.

    No tackiness.

    Std as Ford intended, but with a space saver wheel and jack and nuts and wheel brace. oh.. and flaps, a man has got to have flaps.

    Innit?

     

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.

Please login or register to view this page.




Login or register below to contribute to engine failure. If you're not already a member then you can register for free!